Become a ltxtech.com member, Click here to register!
Mickelson-Horizontal

Page 1 of 138 123451151101 ... LastLast
Results 1 to 10 of 1371
  1. #1
    Xtreme Member


    Status
    Offline
    Join Date
    Mar 2015
    Name
    Dan Dalessandro
    Vehicle
    1997 Camaro Z28
    Location
    Troy,MI or Port Huron, MI
    Posts
    2,073

    Default Dan's Money Pit NYTRDR

    Hey guys and gals, thought I'd throw this on here from another forum.

    So, some history on the car. The car came from Florida in 2007. According to the PO, the guy was in in 60s. It had A HUGE service history from when it was down in Florida. The car is 99% rust free It came to Michigan with around 85k miles in 2007. It is at approximately 107k now. The PO, who was in his mid 20s, put those ugly ass silver shitty quality emblems you see on the car. I put the regular black ones on the sides, and am looking for a custom one for the back. It also had COMPLETE blackout tail lights. I just replaced them yesterday. All the indicators are blacked out too, I'm debating if i want to remove the tint. Brake Fluid supposedly removes it.
    In case you are wondering, "NYTRDR" is like rider of the night.. I like to drive a lot at night. Michigan roads are always busy during the day, and I find some people annoying So it's nice going out at 2 am, and enjoying the fresh air and smell of burning rubber.

    This is my first car, I love it to death, but sometimes I hate it.. LT1 problems right..?

    So what is wrong with the car! I had some cooling problems this past september. When I bought the car, the Water pump started to leak, so it was replaced. So the water pump was replaced in April 2014. In May of 2014, I overheated on my way home from a Meet N' Greet. The radiator cap was shot, and sucked in a shitload of air. So, I installed a manual fan switch, new cap and it ran good. All great all summer, until September 2014. I burned a spark plug wire on my way home, so I went OTVC. All groovy for a week or so. Then I started over heating AGAIN. Did what I should have done when I did the water pump.. replace the thermostat. I first checked it, it would barely open, so ordered a SLP 160. After that was installed, it ran nice, real nice. It was around late October when I started overheating again. Coolant was coming out of the radiator, and the overflow. I decided to pull the radiator out. It was from 99, so I figured it should be replaced. When I did the water pump the first time, the coolant was a brownish yellow color, wasn't healthy at all. I figured the PO had leaks, and put some stop leak shit in it. The radiator was clogged, on the driver side. So +1 for replacement.
    Well, I get the radiator installed, super excited to get the car running again. I pour the coolant in the radiator and BAM, leaking out the water pump. I was so puzzled, so i checked the bolts on the pump, and dingaling ding, the 2 of 3 on the passenger side was loose, and 1 on the driver was loose. Couldn't believe it. I tightened them up, knowing it would only be a temporary fix.
    I also discovered something that I'm pretty damn happy about! The good ol' optispark was replaced by the dealer sometime ago. It looks like it says Aug 16, 2007 or 2001. Either way, the Carfax showed it got a shit load of miles in the first 4 years. I think it was already at 40k in 01. So, either the Optispark is 60kish miles old, or only 15k miles.

    So where is NYTRDR now! Well she's in the garage. Today, I pulled the water pump off. Have to get the o-ring that goes on the water pump shaft though, the part# 12553792, so I'll call up the dealer.

    I have a bunch of other things I'm adding to the car, strut brace... other goodies.
    TL;DR: 19 year old bought a rust free 97 Z from a mid 20s kid who put stupid emblems on it. It has had cooling problems but he cool as fuq.
    DSC00529.JPG
    DSC00532.JPG
    DSC00539.JPG

    14.307@98.21, 2.155 60'

    97 Z28, M6 with stuff done to it. SHOOTING FOR 12s IN A BOLT ON LT1 BOYS

  2. #2
    Xtreme Member


    Status
    Offline
    Join Date
    Mar 2015
    Name
    Dan Dalessandro
    Vehicle
    1997 Camaro Z28
    Location
    Troy,MI or Port Huron, MI
    Posts
    2,073

    Default

    Figured I'd give an update. Well it's not an update sadly. I've been sick, so I haven't been to the garage. College said Norovirus has been going around, hope I didn't get it.. Should be starting again tomorrow hopefully.

    14.307@98.21, 2.155 60'

    97 Z28, M6 with stuff done to it. SHOOTING FOR 12s IN A BOLT ON LT1 BOYS

  3. #3
    "The Rock"


    Status
    Offline
    Join Date
    Jul 2009
    Vehicle
    1996 Camaro Z28, 1994 Trans Am GT, 1985/1996 Corvette CLONE
    Location
    Shillington, Pennsylvania, United States
    Posts
    58,443

    Default

    Hope u feel better. Btw: excellent write up.


    Our BIG MOMENT @ the 2012 LTXshootout

    http://www.facebook.com/photo.php?v=521756391174175

    1996 Camaro Z28: RIP 09/25/2016
    385ci LT1, forged internals, p1sc/intercooled (10.x lbs) AFR eliminator 227s, TD shaft mount rockers, Edelbrock LT4 Air Gap intake, AS&M mono-blade TB, 60# motron injectors, hypertech boost ref fpr,Lonnies dual 255s in tank, AC Delco OPTI fromAMERICAN Powerhouse, Buit T56, 9" with locker/3.90s, 35 spline axels, Pacesetter longtubes, custom Y-pipe into factory style magnaflow, Custom "GLORY HOLE" blow off valve fender escape, SLP SFC and STB,etc, etc, etc $35k and counting....

    602hp/54Xtq
    1994 Trans Am GT: Pace Setter LTs, Magnaflow Muffler, 2500 stall and a CPT A4 (all stock)
    1996 Impala SS H/C with CPT trans and a whole lot more to come...
    2002 Caddilac EscaladeL CAI, lowered, 6.0 , AWD..
    1985/1996GS clone: 207hp/286tq
    SOLD




  4. #4
    Xtreme Member


    Status
    Offline
    Join Date
    Mar 2015
    Name
    Dan Dalessandro
    Vehicle
    1997 Camaro Z28
    Location
    Troy,MI or Port Huron, MI
    Posts
    2,073

    Default

    I come bearing good news. I put the pump on last night, and put her all together today. Turned the car on, love never felt so good.
    Did some interior work too.
    DSC00541.JPGDSC00544.JPG
    I dropped one of the strut tower nuts while attempting to fit a strut brace... It is long gone.. So if anybody knows the size, that'd be great!


    The exhaust was a little smokey. I'm guessing because the car hasn't ran in 4.5 months. I'll throw up a video.


    14.307@98.21, 2.155 60'

    97 Z28, M6 with stuff done to it. SHOOTING FOR 12s IN A BOLT ON LT1 BOYS

  5. #5
    Xtreme Member


    Status
    Offline
    Join Date
    Mar 2015
    Name
    Dan Dalessandro
    Vehicle
    1997 Camaro Z28
    Location
    Troy,MI or Port Huron, MI
    Posts
    2,073

    Default

    Well, fuck my life right.
    Went to go check on the car, was getting ready to pull it out tomorrow. Saw oil on the ground, uh oh no bueno. Felt like a coolant oil mix. I'm like wow fuck.
    Check out, coolant and oil mix. Fuck me. So, looks like a headgasket best case scenario. Or a cracked block/piston/etc worst case scenario.
    Going to be taking it to a shop.. Thought I'd share this great news with everybody.
    Sorry for dropping the f bomb. I'm really not happy right now. :/
    Guess that's what I get for jumping the gun on the damn car. I should have known better when I had to replace the water pump two days after I got it...
    Oh well, it's a money pit already, going to stay one!
    End on a happy note.

    14.307@98.21, 2.155 60'

    97 Z28, M6 with stuff done to it. SHOOTING FOR 12s IN A BOLT ON LT1 BOYS

  6. #6
    "The Rock"


    Status
    Offline
    Join Date
    Jul 2009
    Vehicle
    1996 Camaro Z28, 1994 Trans Am GT, 1985/1996 Corvette CLONE
    Location
    Shillington, Pennsylvania, United States
    Posts
    58,443

    Default

    Get it up in the air and figure out where its coming from. Not normal to just have an oil/coolant mix on the ground coming from a car that was just stored. Keep us posted on what the shop finds.


    Our BIG MOMENT @ the 2012 LTXshootout

    http://www.facebook.com/photo.php?v=521756391174175

    1996 Camaro Z28: RIP 09/25/2016
    385ci LT1, forged internals, p1sc/intercooled (10.x lbs) AFR eliminator 227s, TD shaft mount rockers, Edelbrock LT4 Air Gap intake, AS&M mono-blade TB, 60# motron injectors, hypertech boost ref fpr,Lonnies dual 255s in tank, AC Delco OPTI fromAMERICAN Powerhouse, Buit T56, 9" with locker/3.90s, 35 spline axels, Pacesetter longtubes, custom Y-pipe into factory style magnaflow, Custom "GLORY HOLE" blow off valve fender escape, SLP SFC and STB,etc, etc, etc $35k and counting....

    602hp/54Xtq
    1994 Trans Am GT: Pace Setter LTs, Magnaflow Muffler, 2500 stall and a CPT A4 (all stock)
    1996 Impala SS H/C with CPT trans and a whole lot more to come...
    2002 Caddilac EscaladeL CAI, lowered, 6.0 , AWD..
    1985/1996GS clone: 207hp/286tq
    SOLD




  7. #7
    Xtreme Member


    Status
    Offline
    Join Date
    Mar 2015
    Name
    Dan Dalessandro
    Vehicle
    1997 Camaro Z28
    Location
    Troy,MI or Port Huron, MI
    Posts
    2,073

    Default

    I was going to be changing the oil a few days ago, so I was looking around the oil pan and noticed it was moist. I had the gasket and rear main seal done this past April.
    But to be honest, I'm going to pull some plugs and go from there. I checked the oil, and it was maybe 3 holes over filled. The oil was like a milky yellow color. I knew it was coolant, what else could it be... Sorry didn't make it clear. Wasn't too happy yesterday, but now I'm fine. I'm just happy I have a great family, who like the car as much as I do.
    Now to find a shop.. school > camaro

    14.307@98.21, 2.155 60'

    97 Z28, M6 with stuff done to it. SHOOTING FOR 12s IN A BOLT ON LT1 BOYS

  8. #8
    Xtreme Member


    Status
    Offline
    Join Date
    Mar 2015
    Name
    Dan Dalessandro
    Vehicle
    1997 Camaro Z28
    Location
    Troy,MI or Port Huron, MI
    Posts
    2,073

    Default

    Long story short boys and girls, I was a dingus. Head gaskets are OKAY as of today. Now, my problem with the car besides the leaky water pump was air in the coolant lines. I'm bleeding it to Shbox.com's directions. But this last time, I had it at a shop, a damn good shop. Background on them, they work, no specialize, on C1-C3 Corvettes and other classics.
    So I'm coming home today, and the temp gauge starts climbing. I IMMEDIATELY pull over, pop the hood, no coolant anywhere. Open the bleeders, there is air. Not a lot, but a bit.
    I've had so many problems lol people probably get confused. Where could I possibly have an air leak at? Could it be one of the bleeder screws not forming a tight seal? Another thing, I noticed the sensor on the WP had some moisture on it... I tightened it a little bit before and haven't noticed anything on it since. Any ideas on how air is getting in?
    -Improper bleeding is one, I'll bleed it again.
    -Radiator cap is new. Never replaced the overflow one though.
    -Haven't noticed any leaks but I'll check again
    -Radiator is new
    Hit me with some ideas guys and gals!

    14.307@98.21, 2.155 60'

    97 Z28, M6 with stuff done to it. SHOOTING FOR 12s IN A BOLT ON LT1 BOYS

  9. #9
    LTX Regular


    Status
    Offline
    Join Date
    Jul 2009
    Location
    jacksonville, florida
    Posts
    402

    Default

    Pressure test the coolant system and you will find the leak
    forged 383,9.6:1,280xfi, trickflow heads,edlebrock lt4 intake,moser 12 bolt w/373

  10. #10
    Xtreme Member


    Status
    Offline
    Join Date
    Nov 2012
    Name
    Shaun
    Vehicle
    1994 camaro
    Location
    Lehigh Valley PA
    Posts
    5,155

    Default

    FYI the upper bleeder on the Heater hose is on the suction side of the pump. If you open it car running you can suck air back in and make your issue worse. Get it hot shutdown and bleed. Pumps will only push so much air. Foam is hard to get rid of once you get it
    1994 Z28 T56 - Le2 H/C, SBE, Hooker lt's, some rod ended suspension stuff, and a whole lotta tetanus
    The wrench for LTConvert's 94 Z28- Ellwein 383/LE2 H/C P600B/ CPT Pro Race/Pro Torque 3200

Page 1 of 138 123451151101 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •