Become a ltxtech.com member, Click here to register!
BDBRacing

Page 66 of 66 FirstFirst ... 16566263646566
Results 651 to 657 of 657
  1. #651
    The Nitrous Outlet Junkie


    Status
    Offline
    Join Date
    Apr 2010
    Name
    Troy
    Vehicle
    1994 Firebird Formula
    Location
    bethany, ok (okc)
    Posts
    3,088

    Default

    well I was having problems with my alternator so I finally took her to a shop and had it converted to be a single wire and it works fantastic ... today I took it for my very first test drive out on the roads. I knew it would be smart to stay close to the house in case anything were to happen. So I went about a mile down the road turned got on the highway probably got up to 45 50 miles an hour and I noticed a little bit of steam and then water droplets on my windshield. so I got off at the next exit after approximately one half a mile got off the highway and stopped hopped out to take a look.

    Steam was pouring out around the water pump area. I found out one of the plugs I made had come out partially so thankfully it's an easy fix. I don't believe the motor got too hot. it didn't smell hot.

    So after waiting for about half an hour knowing I had little to no water I drove the rest of the way home which was thankfully less than a half a mile.



    Sent from my SM-N910T using Tapatalk
    94 Formula; sleeper/budget build - total invested so far $2777,
    best pass to date 11.902 @113.73 (forged shortblock coming soon)

    95 Formula, R.I.P (check you oil pump drive gear)

  2. #652
    The Nitrous Outlet Junkie


    Status
    Offline
    Join Date
    Apr 2010
    Name
    Troy
    Vehicle
    1994 Firebird Formula
    Location
    bethany, ok (okc)
    Posts
    3,088

    Default

    Also on my short test drive the transmission got quite hot. I'm running a pretty good size transmission cooler because I have a 4000 stall. Well the transmission got up to around 240 degrees and oddly enough my transmission cooler was completely cold. The car drove pretty good before leaking water out of course. so I'm not sure what's going on with the transmission.

    Sent from my SM-N910T using Tapatalk
    94 Formula; sleeper/budget build - total invested so far $2777,
    best pass to date 11.902 @113.73 (forged shortblock coming soon)

    95 Formula, R.I.P (check you oil pump drive gear)

  3. #653
    Xtreme Member


    Status
    Offline
    Join Date
    Nov 2012
    Name
    Shaun
    Vehicle
    1994 camaro
    Location
    Lehigh Valley PA
    Posts
    5,780

    Default

    Quote Originally Posted by zooguy View Post
    Also on my short test drive the transmission got quite hot. I'm running a pretty good size transmission cooler because I have a 4000 stall. Well the transmission got up to around 240 degrees and oddly enough my transmission cooler was completely cold. The car drove pretty good before leaking water out of course. so I'm not sure what's going on with the transmission.

    Sent from my SM-N910T using Tapatalk
    did you take the plastic plugs out of the trans cooler before putting the lines on??

    Sent from my SAMSUNG-SM-G935A using Tapatalk
    1994 Z28 T56 - Le2 H/C, SBE, Hooker lt's, some rod ended suspension stuff, and a whole lotta tetanus
    The wrench for LTConvert's 94 Z28- Ellwein 383/LE2 H/C P600B/ CPT Pro Race/Pro Torque 3200

  4. #654
    The Nitrous Outlet Junkie


    Status
    Offline
    Join Date
    Apr 2010
    Name
    Troy
    Vehicle
    1994 Firebird Formula
    Location
    bethany, ok (okc)
    Posts
    3,088

    Default

    They were purchased used and there were no caps but thank you I would have noticed that

    Sent from my SM-N910T using Tapatalk
    94 Formula; sleeper/budget build - total invested so far $2777,
    best pass to date 11.902 @113.73 (forged shortblock coming soon)

    95 Formula, R.I.P (check you oil pump drive gear)

  5. #655
    LTX Master


    Status
    Offline
    Join Date
    Mar 2015
    Name
    Stormy
    Vehicle
    1995 Trans Am
    Location
    Washington
    Posts
    582

    Default

    Thats a good leak there. Take a line off the cooler put it in a bucket and start it up. To see if any fluid is pumping. Just for a bit. Not the return line anyways good luck.

    ... on my tablet using Taptalk
    Last edited by Stormyweather; 11-09-2017 at 06:01 PM.



    1995 Trans Am - CAI - TB coolant bypass - Performance Muffler - Poly mounts - stock LT1/A4 - 13.3 1/4 - 1.9 60 foot , driven daily. .

  6. #656
    The Nitrous Outlet Junkie


    Status
    Offline
    Join Date
    Apr 2010
    Name
    Troy
    Vehicle
    1994 Firebird Formula
    Location
    bethany, ok (okc)
    Posts
    3,088

    Default

    Got the water pump properly plugged now time to put water back in and figure out the trans temp issues.

    Sent from my SM-N910T using Tapatalk
    94 Formula; sleeper/budget build - total invested so far $2777,
    best pass to date 11.902 @113.73 (forged shortblock coming soon)

    95 Formula, R.I.P (check you oil pump drive gear)

  7. #657
    The Nitrous Outlet Junkie


    Status
    Offline
    Join Date
    Apr 2010
    Name
    Troy
    Vehicle
    1994 Firebird Formula
    Location
    bethany, ok (okc)
    Posts
    3,088

    Default

    Well now I'm going to be working on figuring out my transmission temperature gauge. I replaced the temperature sensor I still have the same problem.





    Sent from my SM-N910T using Tapatalk
    94 Formula; sleeper/budget build - total invested so far $2777,
    best pass to date 11.902 @113.73 (forged shortblock coming soon)

    95 Formula, R.I.P (check you oil pump drive gear)

Page 66 of 66 FirstFirst ... 16566263646566

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •